How do I do that in Quantum GIS:
illustrating classic GIS tasks

Edited by: Arthur J. Lembo, Jr.; Salisbury University
Introduction from the editor: ................................................................. 4

Database Management ........................................................................... 5
  Adding a Column to a Table: ................................................................. 6
  Sorting Tabular or Graphical Data: ........................................................ 8
  Calculating Values for new fields – using the field calculator: .................. 9
  Joining and Relating Data Files and Fields: ......................................... 11

Database Creation .................................................................................. 14
  Digitizing: ............................................................................................ 15
  Assigning Topology: .............................................................................. 16
  Creating a Polygon from Line Segments .............................................. 19

Import and Export .................................................................................. 23
  Importing Database tables, raster data, vector data .................................. 23

Data Manipulation and Analysis .............................................................. 29
  Data Retrieval ...................................................................................... 30

Raster Analysis ...................................................................................... 32
  Data Extraction by Mask (Clipping Raster Data) ...................................... 32
  Convert Raster to Vector ........................................................................ 34
  Convert Vector to Raster ........................................................................ 36
  Modify raster Cell size by resampling .................................................... 38
  Changing raster values by selected area ............................................... 38
  Changing raster values by geographic feature ....................................... 38
  Vector Overlay ..................................................................................... 39
    Line in polygon .................................................................................. 39

Raster Processing ................................................................................... 41
  Mathematical operations on one raster ............................................... 41
  Mathematical operations on two rasters ............................................... 43
  Neighborhood Functions ....................................................................... 45
  Determining Max/Min .......................................................................... 45
  Calculating Zonal Statistics .................................................................... 46

Statistical Functions .............................................................................. 48
  Calculating Areas Perimeters and Lengths .......................................... 48
General..................................................................................................................................................... 51

Polygons within a distance of selected features....................................................................................... 51

Find Nearest Features..................................................................................................................................... 51

Network Functions......................................................................................................................................... 51

Data Display and Presentation.................................................................................................................. 53
Introduction from the editor:

In 1988, the United States Geological Survey (USGS) created a classic document titled “The Process for Selecting Geographic Information Systems” (Guptill, et. al., 1988). The document provided an overview of the process for selecting geographic information systems, in addition to a checklist of functions that a GIS should include. The functions were broken into five separate categories: user interface, database management, database creation, data manipulation and analysis, and data display and presentation. The document became required reading for those of us involved in the selection of GIS, and was often used as a supplementary checklist in competitive benchmarks of GIS software. Although the document is over 20 years old, many of the functions listed are still relevant today, and represent some of the most commonly used features within GIS. In fact, the document was so forward thinking that most GIS software products are still unable to perform all the tasks listed.

In 2004, a group of my students at Cornell University created the document: How do I do that in ArcGIS/Manifold. After over 30,000 downloads of that document, I felt it was time to introduce the GIS community to another software product: Quantum GIS. This document attempts to illustrate the GIS processes listed in the USGS document using the free, and open source GIS product Quantum GIS. Many individuals are beginning to experiment with Quantum GIS, and it is our hope that this document assists these users in performing some of the more common tasks.

This document represents a week long project for 5 of our advanced GIS students at Salisbury University. Previously, the ArcGIS/Manifold document was developed by 16 students. The resources and time available to illustrate these tasks prohibited the ability to review every function listed in the USGS document. Therefore, we selected a large subset of the functions though to represent the common GIS functions employed by users today. These functions are the same ones found in the ArcGIS/Manifold document. We are especially grateful to those individuals who volunteered as technical referees for each note.

None of the referees were affiliated with Salisbury University, and were anonymous to the authors. One difficulty in creating this document was interpreting the actual meaning of some of the USGS defined tasks. Another difficulty was attempting to find the most suitable approach for solving the problem. As most users know, there are many ways to solve a particular problem using GIS software. In this document we have attempted to illustrate the most straightforward method for performing the tasks, and have relied on the referees to make sure that a suitable approach was chosen. However, any errors remaining within the document are our own, and not the fault of the referees. Also, while Quantum GIS allows for the creation of sophisticated scripts, or integrate third-party software, we have attempted to only utilize those features accessible out-of-the-box (and within the included add-ins) in hopes that it will provide basic guidance for users of the software. It is our hope that this document provides a quick

---

reference for users to find the necessary steps to complete the classic GIS tasks in Quantum GIS.

This report is not yet completed in terms of editing, however, we felt that it was best to offer it to the GIS community, warts and all, so that those interested in exploring Quantum GIS would get a small jump start on their activities.

Arthur J. Lembo, Jr.; Ph.D.
October, 2012
Salisbury University

---

**Database Management**

Database management functions provide for tracking, retrieval, storage, update, protection, and archiving of stored data.

Adding a Column to a Table:
John O'Brien, Salisbury University

This technical note demonstrates the process of adding columns to a table using Quantum GIS. Simple tables are used to help illustrate the process.

1. Open a table

2. → the “Toggle Editing Mode” at the bottom of the table

3. → “New Column”
4. Type in the Name, Comment (optional), Type and Width of the new column in the box that appears.

5. → OK and the new column will insert on the right side of the table.
Sorting Tabular or Graphical Data:
John O'Brien, Salisbury University

This technical note demonstrates the process of sorting tabular or graphical data using Quantum GIS. Simple tables are used to help illustrate the process.

Data can be sorted in either ascending or descending values in any column while maintaining the integrity of the related data for that record in all of the other columns.

1. Open the table

2. → on the header of any column

The data within that column will automatically sort in either ascending or descending order. The data in all other columns will adjust to maintain record integrity.

Data can only be sorted by one field at a time.
Calculating Values for new fields – using the field calculator:
*John O’Brien, Salisbury University*

This technical note demonstrates the process for calculating values for new fields in database tables using Quantum GIS. Simple tables are used to help illustrate the process.

1. Open the table

2. → the “Toggle Editing Mode” at the bottom of the table

3. → Select Field Calculator
4. This will open the field calculator: (In this example I will convert acres to hectares)
   - → Create new Field
   - Name Output field
   - Select Output field type
   - → Fields and Values
   - → ACRES
     - “ACRES” will appear in the Expression box
   - Add mathematical operation to expression box:
     - Use Operators
     - Type in operation

5. Field Calculator will add the new field and populate it with the values

Other Considerations:

The Field Calculator can also be used to update existing fields
Joining and Relating Data Files and Fields:
John O'Brien, Salisbury University

This technical note demonstrates the process of joining and relating data files and fields using Quantum GIS. Simple tables are used to help illustrate the process.

Relating:

Quantum is unable to perform one to many or many to many relation functions at this time.

Joining (Adding and Deleting):

1. After importing files into Quantum open the files attribute tables to ensure that there is a common field for joining
   - R ➔ file in layers area and select “Open Attribute Table” for both files

2. Check for common field

3. R ➔ on the file you want to join to
   - ➔ Properties
4. → the Joins tab in the Layers Properties box

5. → the (Add Join) button in the Layers Properties box

6. In the Add vector join box:
   - → join layer
   - → join field
   - → target field
   - → OK
7. Joined fields will appear on left side of target tables attribute table

8. To delete the join:
   o Open properties in file
   o \(\rightarrow\) Joins Tab in the Layers Properties box
   o \(\rightarrow\) / Highlight layer to be deleted in the Layers Properties box
   o \(\rightarrow\) (Delete Join) button in the Layers Properties box
   o \(\rightarrow\) OK
Database Creation

Database creation functions are those functions required to convert spatial data into a digital form that can be used by a GIS. This includes digitizing features found on printed maps or aerial photographs and transformation of existing digital data into the internal format of a given GIS.

*Page 29, The Process for Selecting Geographic Information Systems*
Digitizing:
John O’Brien, Salisbury University

This technical note demonstrates the process for digitizing points, lines, and polygons using Quantum GIS. Simple tables are used to help illustrate the process.

1. Import Vector / Raster file into project

2. Pan / Zoom to area / feature that you want to digitize
   o ➔ Toggle Edit Mode

3. ➔ Button for function that you want to accomplish in the Edit Toolbar

4. ➔ Save Edits
Assigning Topology:  
*Identifying Intersection Points*

*John O’Brien, Salisbury University*

This technical note demonstrates the process identifying the intersection points of overlapping lines using Quantum GIS. Simple tables are used to help illustrate the process.

1. Import Vector files into Layers

2. → Vector
   - → Analysis Tools
     - → Line Intersections
3. → Input line layer
   o → Input unique ID field
   o → Intersect line layer
   o → Intersect unique ID field
   o → Browse

4. Create / Select intercept shapefile
   o → Save

5. → OK on Line intersection GUI
6. → Yes on pop-up GUI to add shapefile to layers

7. → Close on Line intersections GUI

8. Intersection points will show on layer
Creating a Polygon from Line Segments

*John O'Brien, Salisbury University*

This technical note demonstrates the process of creating a polygon from line segments using Quantum GIS. Quantum has several tools to convert lines to polygons depending on whether the lines have closed or open vertexes. Simple tables are used to help illustrate the process.

**If Lines are closed – no open vertexes:**

1. → Vector
   - → Geometry Tools
     - → Lines to polygons

2. → Input line vector layer
   - → Browse

3. Input or Select File name
   - → Save

4. → OK in Lines to polygons GUI
5. → Yes to add shapefile to layer

6. → Close on Lines to polygons GUI
7. Polygon will display on layer

*If Lines are not closed – open vertexes:*

1. → Feature that you want to change
2. R → Layer group
   o → Save selection as
3. → Name for Save vector layer as GUI or choose Browse
   o → Add saved file to map
       • → OK

4. → New layer and zoom to layer extent

5. → Vector in toolbar
   o → Research tools
       • → Polygon from layer extent
6. Yes to add layer to map
Import and Export

Importing Database tables, raster data, vector data

_Eric Flint, Salisbury University_

**Database**

Database tables, raster data and vector data are all imported under Layer ➔ “Add (Data Type) Layer”

1. To import database layers, select Add PostGIS, [MSSQL], [SpaiaLight] Layers.
2. Select “New” connection
3. Fill in IP address, port, database name, and credentials
4. Select Connect in Add PostGIS layers window
e) Select layers to be added

f) Raster Data
   
a) To import raster data select “Add Raster Layer”

   b) Navigate to desired raster data file
c) Select “Open”

![Image of Quantum GIS Open a GDAL Supported Raster Data Source]

![Image of Quantum GIS with selected layer]

d) Right Click on layer  
e) Select Properties  
   a. Under Style tab  
   b. Select Layer properties
Vector Data

a) To import Vector data select “Add Vector Layer”

b) Navigate to desired vector data file

c) Select “Open”
How do I do that in Quantum GIS

(c) Arthur J. Lembo, Jr.
Data Manipulation and Analysis

Data manipulation and analysis functions provide the capability to selectively retrieve, transform, restructure, and analyze data. **Retrieval** options provide the ability to retrieve either graphic features or feature attributes in a variety of ways. **Transformation** includes both coordinate/projection transformations and coordinate adjustments. **Data restructuring** includes the ability to convert vector data to raster data, merge data, compress data, reclassify or rescale data, and contour, triangulate, or grid random or uniformly spaced z-value data sets.

**Analysis** functions differ somewhat depending on whether the internal data structure is raster or vector based. Analysis functions provide the capability to create new maps and related descriptive statistics by reclassifying and combining existing data categories in a variety of ways. Analysis functions also support: replacement of cell values with neighboring cell characteristics (**neighborhood analysis**); defining distance buffers around points, lines and areas (**proximity analysis**); optimum path or route selection (**network analysis**); and generating slope, aspect and profile maps (**terrain analysis**).

Page 29, The Process for Selecting Geographic Information Systems
Data Retrieval
Select Data

1. Select “View” → “Select” on the dropdown toolbar

2. Select Features by Rectangle
Can Select Features by; Single Feature, Rectangle, Polygon, Freehand shape, Radius
**Raster Analysis**

**Data Extraction by Mask (Clipping Raster Data)**

1) Select “Raster” in the Dropdown toolbar then select “Extraction” → “Clipper”

2) Fill in required boxes in form
How do I do that in Quantum GIS

(c) Arthur J. Lembo, Jr.
Convert Raster to Vector

1) Select “Raster” from dropdown toolbar

2) Select “Conversion” → “Polygonize”
How do I do that in Quantum GIS

(c) Arthur J. Lembo, Jr.
**Convert Vector to Raster**

1) Select “Raster” from dropdown toolbar

2) Select “Conversion” → “Rasterize”
How do I do that in Quantum GIS
(c) Arthur J. Lembo, Jr.
Modify raster Cell size by resampling
Not currently readily available in QGIS

Changing raster values by selected area
Not currently readily available in QGIS

Changing raster values by geographic feature
Not currently readily available in QGIS
Vector Overlay

Line in polygon

1) Select “Vector” in dropdown toolbar

2) Select “Geoprocessing Tools” → Clip

[Image of Quantum GIS interface showing vector overlay process]
How do I do that in Quantum GIS

(c) Arthur J. Lembo, Jr.
Raster Processing

Mathematical operations on one raster

1) Select “Raster” from dropdown toolbar

2) Select “Raster Calculator”

3) Click on trigonometric function then double click on Raster band.
4) Select output layer path and format
Mathematical operations on two rasters
Adding / Subtracting Rasters

1) Select “Raster” from dropdown toolbox

2) Select “Raster Calculator”
Subtracting

How do I do that in Quantum GIS

(c) Arthur J. Lembo, Jr.
Neighborhood Functions

Determining Max/Min
Calculating Zonal Statistics

- (Raster filtering is available through GRASS plug-in in Quantum, but is not currently readily available in QGIS)

1) Select “Raster” From dropdown toolbar

2) Select “Zonal Statistics” → “Zonal Statistics”

3) Right Click on “poly” layer (layer containing zones) Select “Attribute Table”
How do I do that in Quantum GIS

(c) Arthur J. Lembo, Jr.
Statistical Functions

Calculating Areas Perimeters and Lengths
  1) Right Click layer select “Attribute Table”
  2) Toggle Editing button to on
  3) Toggle New Column to On or (Ctrl+W)

4) Select Field Calculator Button
5) Perimeter
   a. Select New Column

6) Lengths
   a. Toggle on Editing button
   b. Select Field Calculator
How do I do that in Quantum GIS

(c) Arthur J. Lembo, Jr.
General

Polygons within a distance of selected features.
There is no option for within a distance of in the spatial query tool. The only options are: contains, intersects, and is disjoint. Greater query power is available in GRASS.

Find Nearest Features
no tool in QGIS but note that further capabilities are present in GRASS.

Network Functions:
In QGIS it is possible to perform some simple network functions. It is necessary to start with a vector line layer, generally one would use centerlines or whatever road data they have access to.

In order to build a road network, QGIS provides a ROAD GRAPH tool. To get to road graph, select the vector tab, and scroll down to road graph and select settings.
In the Above window that pops up you have the ability to use attributes from the selected layer to set a direction field, and even a speed field if available. This is convenient as it allows for simple network creation all within the GUI.

![Screen shot of Shortest path dialog box](image)

So now that the network has been established it is possible through the shortest path plug in to calculate the shortest path. Another innovation not found in some of the proprietary alternatives is the ability to interactively select the start and stop points.

Defining drive-time zone: QGIS does not appear to have an available plug-in for defining drive-time zone.

**115. Geocoding addresses:** Quantum makes this possible with a geocoding plugin. There is a plugin that allows for one address at a time.
So long as the current map is projected and the address is accurate the tool makes a point for each address entered. In order to geocode multiple addresses it is not as simple. It is possible through limited research on the internet but is not a standard procedure.

Data Display and Presentation:

**Thematically Shade Polygons**: It is possible to color or shade layers based on a specific attribute of that layer. To access the properties window for a layer you must double click the desired layer in the layers window. The resulting window is below:

1. Double click on the layer of interest in the layer pane. The layer properties window will open, make sure you are on the Style Tab.
2. Fortunately we are already on the style tab and its on the top left of this tab that it is possible to make thematic changes to the map. Options include single symbol, categorized, graduated, rule-based, point displacement. So once a symbol style is selected the following window opens.
3. Select the attribute field you want to analyze/visualize. It’s also in this window that you can select a color scheme and label based on the color scheme break up.

**LABELS:**

1. Double click the layer you wish to set labels, in the properties window select Labels. Select the Display labels box.
2. In the window above it is possible to select the label displayed based on features attribute field. Also to alter the font, font size, label placement. You have options to set scale dependent labels, and even buffer the labels.
Adding North Arrow or Scale Bar:

1. To add other thematic items in quantum go under the view tab and select decorations the options include: north arrow, scale bar, and copyrite label.
How do I do that in Quantum GIS

(c) Arthur J. Lembo, Jr.
2. Important to remember when implementing a scale bar that the map units should be set to the desired units. This can be accomplished under Settings>Project Properties and in that window.

**Printable Map Layout:** Quantum does have a layout option that is under File>Composer Manager under which the user can add the desired map and make thematic changes to a printable map.

**Adding Items to Layout:**

The user can add maps, labels, scale bars, legends, N. arrow, and even attribute tables.

1. In order to add each item the user selects the item they wish to add in the top toolbar and then uses the mouse to click and drag that item to desired location and size. Items are able to be manipulated once they are added.
2. QGIS has a commands history window that keeps a log of the users commands within the layout, a nice feature when needing to go back to make changes.
3. There is also a side window with item properties and composition tabs. This is where changes can be made to properties. For example select the scale bar and in its properties tab you are able to alter the segment size, map units per bar and assorted other aspects.
4. 

![Command History](image)

![Item Properties](image)
6. QGIS even has some basic graphic editing tools (i.e. group selected, align selected left)
7. Example of the Composer Manager (Layout View)
How do I do that in Quantum GIS
(c) Arthur J. Lembo, Jr.